Upload file 400 error

One of our users is getting an error when trying to upload a small PDF document.
We cannot replicate the error, as the same file is uploading fine when we do it.

The error message is Failed to load resource: the server respsonded with a satus of 400 (Bad Request) api.backendles.com/..df?overwhrite-true:1


Here are our settings for the File Uploader Button

Here is my App id 4A47197B-AE30-FA84-FF56-0071F4010900

Here is a video of her uploading the file.

Hello @Andreas_Marinopoulos,

could you please provide us with the following info:

  • what do you see in the Network tab? There should be failed request and if you click on it, it should show the details - error message, etc.
  • what type of file are you trying to upload? Is the problem only with this file or with files uploading in general?
  • how can we reproduce it?


Hi @stanislaw.grin the error we are receiving from this user is:

{"code":6006,"message":"Path contains prohibited symbols: homework/George's HW BG 6.07.pdf ","errorData":{}}

When removing the special symbol it worked.

I do not get the same error.
Are you aware of any such issues that are maybe linked to older operating systems or browsers?
Do you recommend that, wherever we use an upload button, we use code blocks that strip filenames of special symbols?

Hi @Andreas_Marinopoulos ,
I’ve reported a similar issue some time ago and a solution was provided.
See Issue with filenames with spaces