Uploaded file in console file browser causing strange "ghost" file

Backendless Version (3.x / 5.x, Online / Managed / Pro )


Client SDK (REST / Android / Objective-C / Swift / JS )

Console/Files browser

Application ID


I’ve uploaded a file using the file browser in the console, specifically a codegen .xsl file:

Though it seems to be in some strange state, where if I refresh file browser table, it will either appear or not be there at all. Attempting to edit the file will either let me edit the file as you would expect, or give me the error: “The specified resource was not found”

Trying to delete the file also produces mixed results.

As a second attempt, I’ve tried uploading the .xsl in a compressed zip, then unzipping, and now it’s doing a similar thing where it will either show the .zip, .xsl, or neither.

I have also uploaded the codegen .js generator file under the generators folder, and that seems to have worked fine. Just the above file(s) appear to be causing some kind of issue. I have a feeling something erroneous happened when originally uploading the .xsl file, but not really sure what.

Any help appreciated, thank you



Just to help better illustrate, here you can see the different “states” of the file where by clicking refresh it will result with one of these:

Hello, @Nathan_Cousins.

Its expected behaviour.
‘codegens’ is the system folder, you cannot write anything here.
You can create your own folder (for example, for this route “Root-> myOwnFolder”).

Best regards, Nikita.

Good to know, thanks Nikita