Support Topics Documentation Slack YouTube Blog

Urgent, getting Bad Request (400) on deployed code, worked like a charm until yesterday


(Alessandra Saviotti) #1

hi there,
I am using the backendless library for angular for a project that is already deployed and used by many.

It all worked fine until yesterday, without any change in code or on the server, I now get bad request (400), it seems the request is associated to a specific table called “CoachNoCoreData” as well as “CoachRequestNoCoreData” in application ID ‘9088AF67-1648-1726-FF09-A51862BF1A00’). I’m on backendless 3 for legacy reasons.

Note that for some reason it doesn’t trigger all the time, but really often, any ideas?

I’m not sure what I can do as it was all working fine and nothing has changed. The exact same request sometimes works and sometimes returns bad request, how is that possible?


(Mark Piller) #2

Hi Alessandra,

We’re investigating the problem. I suspect it occurs when a request is picked up by a coderunner which doesn’t see the business logic - this is the problem we’re solving now.

Regards,
Mark


(Alessandra Saviotti) #3

thank you Mark for the prompt reply, keep us posted.


(Mark Piller) #4

Hello,

The problem has been resolved. Please check and confirm.

Regards,
Mark


(Alessandra Saviotti) #5

all good, thank you for the prompt help as usual. Feel free to delete the thread, probably not relevant for others at this point.