Support Topics Documentation Slack YouTube Blog

Cannot unzip file in console (v3)

Hi,

We are using Backendless v3 and our application ID is C6730F91-F429-E4C9-FF61-ED62B2B2E100

I am unable to unzip files in the file section of the web interface. A notification pops up that the file will unzip, but I get no email of success or failure and no files appear.

I tried zipping our main data folder a couple of days ago, to create a backup, but that didn’t succeed. Maybe that process crashed and the zip/unzip service is in limbo somewhere now?

Kind regards,
Jeroen

Hello Jeroen,

We are able to reproduce this issue.
The internal ticket BKNDLSS-18495 is created and we’ll respond here as soon as it is fix.

Regards,
Olha

Hi @Jeroen_Dierckx

Would you like us to unzip required file manually before we make a fix for general cases?

Anton

@Jeroen_Dierckx
I believe the issue is of the same nature as in support ticket you’ve posted before. You ran out of your disc space. I would recommend to enable auto-purchase for the file storage component to avoid these kind of problems in future - https://monosnap.com/file/ZDquJ0cpPOsXU6WRLRKnwXGis5cHK2

Anton

Could it be that the disk space calculation is off? There is no way that our normal data would have put us over our disk space usage. We were just over half of the disk space and slowly growing.

I tried zipping recording data (a couple of times), but that zip file never appeared. That was the reason for starting this support request, because unzipping also failed after that.

The zip file of the data could have been too large, if it would have succeeded. Maybe the partial zip file is in a hidden file somewhere that counts towards the disk usage?

Kind regards,
Jeroen

The calculation is on and works fine. Here is how your root directory looks like:

11G BioracerMotion
8.6G migration-to-4
584M BioracerAero
250M BioracerAero.zip
6.5M logging
5.7M servercode
1.3M export
949K servercode.zip
443K web
116K web.zip

The most part of the space takes BioracerMotion/data size of which is about 11GB (11109718 KB).
Migration zip takes almost 9GB. So there is nothing wrong with usage count. You may delete migration-to-v4 directory and free up about a half of disk space

Anton