{ "code" : 17000, "message" : "No script runner is available" }

Hi,
Just started seeing this returned in responses from hosted code.

{ “code” : 17000, “message” : “No script runner is available” }

Anything going on with infrastructure or does this indicate that my hosted Node.js is causing issues?

Thanks,

-Ankit

Hi Ankit,

Could you please check now?

Mark

Thanks Mark for the quick response, but still same error:

Object {code: 17000, message: “No script runner is available”}

I installed the backendless on my own digital Ocean server. Do you think I need to install something ?

I am trying to deploy coderunner to server. I think I need to change runner.properties file.

Can you please guide me what all value I need to change ?

Oh, that’s an important detail. The standalone server does not currently support the node.js container the same way our Cloud Edition does it.

Is there any way I get my cloud code working ? I want to make stripe payment using cloud code. Could you please suggest some alternative ?

You should be able to do it using Java business logic, that is supported in the Standalone edition.

Thanks, let me try that. I will reply back in sometime.

I create a Java project and included Backendless.jar and stripe.jar under project dependency. While I invoke the service, I am getting following response:

{
“code”: 0,
“message”: “java.lang.NoClassDefFoundError: com/stripe/StripeServiceException”
}

Ankit,

Are you trying to run it locally or deploying it to your Digital Ocean installation?

Mark

Everything on Digital Ocean . I dont have local setup.

I created Java project locally in eclipse, create the JAR file out of it, and upload it under Business Logic -> Api Services.

I see. Make sure to take backendless.jar out of the packaging. Also, did you create a flat fat jar? Meaning the .class files for Stripe are inside of the jar you deploy (and not in a jar within a jar).

Mark

Yes, stripe jar files have .class files inside. As per you suggestion, I deleted backendless.jar file from my code, and create jar file. Getting error on uploading jar file now.

Please note:

public class CloudCodeServices implements IBackendlessService

Thats how I initialized my class.

Does CloudCodeServices belong to a package?

Are there other jars inside of the jar you’re uploading?

Yes, CloudCodeService is under package com.mbaas.services

There is only stripe-java-1.44.0.jar

Could you share that jar with me, I’d like to try it in my app. Either google drive or dropbox link will work. My email is mark@backendless.com

sent, let me know if you didn’t get.

Yes, I got it. You did not package it right. I wrote that:

    you cannot have jars inside of the jar backendless.jar must be excluded.
You didn't handle either one of these: http://support.backendless.com/public/attachments/d7f8b2302f18cc295ffb083ab54cc34b.png</img>

Mark, I tried all possible option. Please let me know :

  1. Where should I place backendless.jar
  2. How do solve, stripe expanded jar.