Could not publish UI-Builder container "default"


I can’t publish my app. I get an error message
Could not publish UI-Builder container "default"
Trying to publish to /web/default
App ID is D7075715-5086-625A-FFAB-39C2F40FB200


Hi Nicolas,

I see the /web/default directory was created today. What directory did you previously deploy the UI container to?


It used to be to /web/049
I created /web/0410 today for the next version, and it didn’t work.
So I emptied /web/049 and tried, it didn’t work either.
Then I created another folder /web/default, and no success either.

Do I understand correctly that publishing to any of the directories worked?

Have you checked if any of the pages when you run them in the preview mode give you any errors?

Sorry if I was unclear, publishing to any of those directories today did NOT work.

I have not had any errors, no.

Just to be clear, this is the only error I get

When you initiate a UI container publication, the system “assembles” your app. This means it works through all the pages, their logic, and custom functions and creates one cohesive package. If there is a problem with any of these components, the system would not be able to publish the UI container as it would be deemed as “broken”. Hence is my question, have you checked if any of the individual pages in your UI container report problems on their own?

I have not seen any problem, no. I have 30+ different pages, so I did not run through them all. But normally I have only changed about 2 or 3, and these have not been problematic. This is why I am puzzled.

Would there be a log somewhere of the “assembly” process, in order to help me pinpoint where the issue would be ? Because otherwise it’s going to be a pretty long and random process.

Yes, there is a log that we will check. I opened an internal ticket to investigate the problem.


1 Like


Hi Mark,

I believe I might be on to something : on one of my pages, I got the following error.

Can not render page due to error: "Script error for "pages/L2-view-log-entry-detail/components/2afc8746117f19e81c64d77cb5826146/bundle.js""
Error: Script error for "pages/L2-view-log-entry-detail/components/2afc8746117f19e81c64d77cb5826146/bundle.js"
    at makeError (
    at HTMLScriptElement.onScriptError (

The thing is that there is no folder named 2afc8746117f19e81c64d77cb5826146 there…

Indeed, I believe it is a component I removed. And if I remember correctly, there was a server connection error at that time. So I retried and everything seemed to work OK, so all was good. But in fact no, it looks like something is messed up and I can’t find where it is actually looking for that 2afc8746117f19e81c64d77cb5826146 component.

Are you able to publish the UI container now?

Unfortunately no, because somehow it’s still looking for that component. But it’s not there anymore ! And I downloaded the whole UI container code and searched the text. Nowhere is that 2afc8746117f19e81c64d77cb5826146 component found. It would be great if someone could have a look at it.

Hello @Nicolas_REMY

Are you still not able to deploy the UI-Container?
If there are errors in the preview mode it won’t be able to deployed(published)
however, I do not see any issues in the preview mode.

We are going to improve the error message “Could not publish …” to provide more details why it’s not possible.

Hi Vladimir,

I tried this evening and it worked, which is great.
Please note that I did not change anything between yesterday and today : I was out and about and did not work on the project at all, so I don’t really get what was wrong and what made it right.
Did you find anything in the log about the errors from yesterday ?

yes, there was an issue with sync model and UI, and after opening the page it was healed by itself.