Support Topics Documentation Slack YouTube Blog

Deploying production to Dev enviornment

Team,

I am trying to sync changes from production to the dev environment and getting error shown in the screen
help me on this please.

Please provide the following:

  1. Application ID of the app you’re deploying from
  2. Application ID of the app you’re deploying to

Regards,
Mark

Hey Mark

  1. 5DA64846-E3FA-C63E-FF1B-E265995AA700 (deploying from)
  2. D53DE733-2365-4455-914E-9CAD080BE242 (deploying to)

@mark-piller Please update on this.

Hi @Baljeet_Singh !

Sorry for delay with response.
In your case Backendless is unable to locate scheme for some of your Codeless services in source app - if you hover your mouse over red icon you will see message about it.

Could you please try to redeploy all your services in Codeless tab and try again to sync changes? During redepoy missing scheme should be created automatically. If simple redeploy will not help you I will create internal ticket and pass it to our engineers for investigation.

Regards, Andriy

@Andriy_Konoz
Just tried the solution you said


unable to solve

@Baljeet_Singh

Sorry for inconvenience. I have created internal ticket BKNDLSS-24549 for this problem. Our engineers will look to it as soon as possible.

Regards, Andriy

Hello @Baljeet_Singh,

I have fixed the issue, could you please try again?
The problem was with installed plugins from the marketplace, for some reason they weren’t available.
I have reinstalled them and the error is gone.
Have you installed Apple Login plugin in both apps on your own?

Regards,
Stanislaw

Thanks, It works fine now

@stanislaw.grin
I deployed production to the dev environment but I am not able to load Timer Logic designers, can you please check once. Attaching error of console

@stanislaw.grin
Just checked, its working in icognito.

@stanislaw.grin
It’s very unstable in Dev Env.
I am facing this issue now.


Although I have synced all the production changes to Dev and also I can see the function in dev env.
but still it’s throwing error like that Its not available.

I am trying in incognito as well.

Hi @Baljeet_Singh,

for some reason your timer logic is empty on dev env. I suppose this happen while syncing changes.
Is this the only issue you have or you are facing same errors in other timers?

@stanislaw.grin
May be only this m not sure. I just deployed and tried whatever was prior.
I tried to re deploy as well in dev env. but it didn’t work.

Thanks for info @Baljeet_Singh ,

we have made some changes, we need to check it right after the nearest release.
I’ll keep you informed here about any progress.
Sorry for the inconvenience!

Regards,
Stanislaw

Thank you, @stanislaw.grin

@stanislaw.grin
Any update on this! :slight_smile:

Hi @Baljeet_Singh ,

may I try to sync changes from your prod app into dev?

Sure.

Unfortunately the fix does not work. We keep looking for a solution to the problem.
Thank you for your patience!

Regards,
Stanislaw