Support Topics Documentation Slack YouTube Blog

Getting Access Denied error during n after time of recent maintenance notice

Are you looking for help?

This is a support forum for reporting issues related to Backendless services. Please note that due to our support policy we cannot provide you help with debugging your code, consulting in regards to any language or third-party library usage. For this kind of questions we recommend using more appropriate forums like Stack Overflow.

In order to suggest you a quality solution, we shall usually ask you to provide the details mentioned below first. Including them into your topic right away helps us to start investigating your issue much faster.

In case you have a suggestion or an idea, the details below are not always required, though still any additional background is welcome.

Backendless Version : 6.0.1

Client SDK : .net

Application ID: 4E129FA8-ED2B-5021-FF84-966E95BC0D00

Expected Behavior

Calling CustomService api via .net sdk.
The api call should work (as usual)

Actual Behavior

Instead, getting exeption. Details:
BackendlessFault. Code: 14008, Message: Access denied

Reproducible Test Case

Calling api method “create”, of service “admintoken”.

Please provide values for the arguments so we can try reproducing the error:
API Services - BL - SOAP_Licensing - Backendless 2020-07-22 08-46-14

{
“admin” : “kinjal@dwaravati.com”,
“token” : “7E786052-3601-49AE-82BE-34D0C95996B8”,
“ownerId” : “41752C01-D10D-03E2-FFA8-C447E0A40600”,
“motherboardId” : “W1KS97M104N”,
“processorId” : “BFEBFBFF000906EA”,
“soapVersion” : “2.2.1.0”,
“revitVersion” : “2021”
}

Here’s what I get:

let me re try from my end (via .net)…

i still get the same error…

What does the method invocation look like? Are you invoking via REST or using the generated code?

We are invoking it from our .net application using sdk.

Here is screenshot of the same:

fyi, we started facing this issue in about last 2.5 hours (after a few mins of maintenance announcement, and through it was related).

please let me know if there is anything i can do in the meantime to help find the cause sooner!

Hello, could you provide your App_ID and part of the code in which this request is made?
Regards, Nikita

you mean, this? Application ID: 4E129FA8-ED2B-5021-FF84-966E95BC0D00

Can you please elaborate on what exactly you are looking for in code (other than above mentioned screenshot) so i can shared it? As such it is single line of call to the api.

@Kinjal_Desai, we’re investigating the problem.

Thanks,
Mark

Thanks… please keep posted… and i am available if i can be of any help…

@Kinjal_Desai, could you please check if other methods can be invoked from .NET?

Calls like following works.

Backendless.UserService.Login(email, password, false)

I’ll try to check for other CustomService calls.

Please let me know.

Tried Backendless.CustomService.Invoke<List>(“analyticsservice”, “fetchCompanyAdmins”, args).

Looks like the call is stuck since long (5+ mins) and would in general hit timeout.!

Tried another one (following), it resulted in same error (Access Denied). There was not wait like prev test, it resulted in exception immediately.

Backendless.CustomService.Invoke<Dictionary<string, object>>(“admintoken”, “validate”, args);