Internal server error with id E9B7AC3B-D9E6-6309-FFB0-0F16A911B200

Hi there,

We have a table called Events. I delete a property in console called “user” (string) and changed a class in my code to add the field again, but this time as a relation. Now I get the above error when trying to access the Event class.

My App Id is 6B0D8C39-40E5-BC10-FF0E-BC967700C300

Thank you.

Internal server error means there is a problem on their server, it’s not something on your side. They said they worked on the server to make it faster and stuff like that…Yesterday it worked, now it has moments when it’s working and moments when it doesn’t, giving Request Timeout error or other server-related error. Personally, I am getting enough of this.

Yes, it was working very well for a while. Haven’t had the timeout problems since they fixed the issues, but these problems have set our development back tremendously.

Same thing for me with the development part. I’m about to lose my client because of my decision to use this service.

Then we’re in the same boat. My client is extremely unhappy. Thankfully Backendless has pretty good support and are quite responsive to requests. I just hope stability can be attained and maintained when our application goes into production.

It’s good that you are positive man, but I’ve already lost my faith that they can provide a basic functionality and responsiveness.

I’m trying to stay positive but I just got a “backend server is at capacity”, so it’s going down hill on the positivity. I know they can’t guarantee anything in the clouded version, but we can’t even get a 1-user app in development to function properly. So we are never getting to the point where a jump to their managed solution makes sense. Anyway, best of luck with your app. I hope you catch up and keep the client.

Long response times, timeouts, 500, 502, 503 errors, wrong error codes, not working functionalities. Get used to it.

I’ve deleted and trying to recreate a table from code.

Now I’m getting this error:

{“java.lang.RuntimeException: java.lang.RuntimeException: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table ‘6B0D8C39-40E5-BC10-FF0E-BC967700C300.Event.FF140C85-1E36-4398-FF74-A14DF43EA400’ doesn’t exist”}

If you didn’t know, the managed service starts at $ 2,500 / month for 50 API calls (or at least that’s what I’ve been told). Who will pay that amount of money without having a MVP (minimum viable product) first?

@Matt That’s what I’m getting now, those codes, I don’t really know when to expect it to work and when to just wait for a solution.

Whoa, that’s a big step up. Exactly, without a MVP, it’s not a step one is likely to make.

@Cristian For me those errors appear randomly so also don’t know when to expect it to work. Waiting for a solution seems like a bad idea - I’ve opened a few tickets more than month ago and they are still not closed. I’m using only REST API even I’m creating an Android app and managed to set up things up and working without continuous errors after few (probably 3 different) database structure implementations.

My current approach is to have data tables without any relations (loading data with relations is slow and cause errors) and cache as much as possible. This way I need to make more requests when creating data and also part of the data is duplicated but I have less GET requests.
Less requests = less error responses.

@Matt Thanks for your advice. For my app, updates need to be made on a particular object and the rest of the users has to see that object updated, so I have objects that needs to change their properties based on the action of a user, and I really need these requests to work. These problems leads to inconsistency in my case. But I’m glad that you found a workaround.

Hi Philip,

With what app version you have this issue?



Hi Denys,

I’ve re-created the Event table, and it appears to be working. It was in “v1”. Data access seems to be working quite well, but push notifications (only tested on iOS) aren’t going through.

And now push is working again…

Philip - from my experience - if you run the app directly on the device, make sure you use a Dev push notification certificate. If you run it from Test Flight, you will ned a Distribution one. One more thing I noticed - put a password on your certificate; I don’t know why, sometimes for me it didn’t work if I had a certificate without a password.

If I create a distribution certificate, will I be able to use that during testing and Test Flight at the same time? I’ve created a sandbox and distribution certificate.

I think it’s working now and I think (know) the error was on my part :slight_smile:

I think you can’t do that… it only accepts a single certificate. Backendless guys - please correct me if I’m wrong.