Issue with Image Reference

I have an issue, I have uploaded images in Images folder. From there I can preview images.

I have one table with FileReference column. When I link images to file reference, then those images do not show up in preview and when I access from dotnet app, they don’t show up there.

Same behavior is with guest user and logged in user.

Help need to resolve this. Thanks in advance

Hello @Ali_Sakhi

Welcome to our community and thank you for trying out Backendless

As I can see the following file is not shows up. Is it correct?

There are more like this. These ones

But if I open the file directly from file section they load, with below urls

The urls that do not work are returned by rest api, and dotnet sdk.

Seems when I copied the url here they are showing up

It looks like the links are working since the forum managed to fetch/render the images.

Thanks Mark.

Yes, but if you copy the url in browser or use in app it is not working, which is the main issue.

Is there in setting I am missing, but some times it works.

I am on free plan is that issue.

Every image has two URLs. The ones you listed here are “console” URLs, they are available only to you when you’re logged in to console:

a public URL for an image can be obtained here:

You can read about file URLs in the product documentation at:

Hope this helps.


But when I link the file in table then it generates different url then the public one. Below screen shots show how the files are linked, and the output from rest console. If you copy the link from rest console in browser it does not work.

Can you copy and paste that link as shown below:


Here it is the url from rest console.

But the public url is

and console url is

The public URL shows up in a browser just fine:

Yes. But when I query the table the link that comes with it, is not working and different from public url.

I am using file reference column.

Here’s what I get with that link:

Hi Mark

I am getting the below error. This app is in EU zone.

Can you try it on your mobile device?
Can you try it on another computer?
Do you have an antivirus installed?

I tried this on PC and Mac both. I tried in office at home. I tried on 5G. and tried to connect vpn of other country office.

I do not have any separate antivirus. I tried on mobile device also.

Well, it works on the forum - you saw that.
It works on my PC - you saw the screenshot.
I just tried on my mobile and it also works.

We need to be able to reproduce the problem in order to assist you. Unfortunately, everything we have tried, produces the expected result. Image opens up just fine.


I just tried to connect with Public VPN and the images started to show up. Last time it was working I was in Pakistan.

I noticed that this issue is coming since I am in UAE.

Seems like something with UAE traffic.

Also I tried to create a new app in US zone. From there images are working.

Is it possible to change the app zone. As I have paid for springboard plan for this one.

Hello @Ali_Sakhi

Do you need to migrate your application from one zone to another (in this case there will be a migration fee) Or are you willing to create a new application in the US zone and delete the old application in the EU zone (in which case we can migrate the springboard from one application to another for you)?