Missing Timers in Cloud Code Deployment


I’m deploying a model in coderunner that contains two timers. No errors, as you can see below. The log shows two timers, but only one timer shows up in the Bus Logic console. This timer existed and ran fine before the new deployment. The Coding tab in Bus Logic does not show ANY files under the timers folder. I’ve tried adding both timers in a single file, and deploying using two files, no difference. At one point I got a message saying I was exceeding my script count resource, but I cleaned out some old models used only for testing and the message went away. Perhaps I am misinterpreting what constitutes a “script.” Any advice appreciated.


2021-11-18 01:11:55,164 | SERVER_CODE |  INFO | [22060] [ANALYSE CODE] codePath: /opt/backendless/repo/8149fcce-07da-f988-ffbb-6154872c9500/files/servercode/JS/Test/DRAFT
2021-11-18 01:11:55,170 | SERVER_CODE |  INFO | [22060] Building Model..
2021-11-18 01:11:55,181 | SERVER_CODE |  INFO | [22060] ServerCode Model built in 11ms
2021-11-18 01:11:55,184 | SERVER_CODE |  INFO | [22060] Processing finished in 47.846ms
2021-11-18 01:11:55,900 | SERVER_CODE |  INFO | [22082] [ANALYSE CODE] codePath: /opt/backendless/repo/8149fcce-07da-f988-ffbb-6154872c9500/files/servercode/JS/Test/DRAFT
2021-11-18 01:11:55,905 | SERVER_CODE |  INFO | [22082] Building Model..
2021-11-18 01:11:55,910 | SERVER_CODE |  INFO | [22082] ServerCode Model built in 5ms
2021-11-18 01:11:55,914 | SERVER_CODE |  INFO | [22082] Processing finished in 33.387ms
2021-11-18 01:31:19,530 | SERVER_CODE |  INFO | [17931] [ANALYSE CODE] codePath: /opt/backendless/repo/8149fcce-07da-f988-ffbb-6154872c9500/files/servercode/JS/partsscan/tmp1637199070043
2021-11-18 01:31:19,533 | SERVER_CODE |  INFO | [17931] Building Model..
2021-11-18 01:31:20,223 | SERVER_CODE |  INFO | [17931] ServerCode Model built in 690ms
2021-11-18 01:31:20,223 | SERVER_CODE |  INFO | [17931] Timers (2):
2021-11-18 01:31:20,223 | SERVER_CODE |  INFO | [17931]   CleanupPartsscan (timers/CleanupPartsscan.js)
2021-11-18 01:31:20,224 | SERVER_CODE |  INFO | [17931]   CleanupPartsscanFiles (timers/CleanupPartsscan.js)
2021-11-18 01:31:20,224 | SERVER_CODE |  INFO | [17931] Custom Types (1):
2021-11-18 01:31:20,224 | SERVER_CODE |  INFO | [17931]   Db (models/db.js)
2021-11-18 01:31:20,224 | SERVER_CODE |  INFO | [17931] Services (1):
2021-11-18 01:31:20,224 | SERVER_CODE |  INFO | [17931]   PartsScan (services/PartsScanService.js)
2021-11-18 01:31:20,227 | SERVER_CODE |  INFO | [17931] Processing finished in 709.822ms

Hello @Kelly_Oglesby

We will investigate the issue and let you know the result as soon as possible. We apologize for the inconvenience.


Hi. Could you send us (with link here or or via an email sent to support@backendless.com) entire archive with coderunner and the timer’s code.

Was my archive mail received? I sent it the same day. This project is still having problems. I performed a coderunner deployment with modified service code tonight. It deployed without errors, including the ones described above. However, the previous code remained in place and my changes were ignored. I deployed it again, same result. I HAD to replace the code immediately, so I edited the code in the Business Logic → Coding tab. I deployed it from there, now the changed service code works, but my timers disappeared.

Sorry, but we didn’t find the letter with the coderunner archive.
The only letter we found is related to that topic > Import Apparently Failing, But without Error - #2 by mark-piller.
Could you resend it today, please.

Thank you, Oleg. I resent it.

Hello @Kelly_Oglesby

Sorry but we still do not see any new emails from you, did you send them to support@backendless.com?

Regards, Vlad

Vlad, I sent again using a different email client - gmail security ate the zip file probably. I sent two emails, ignore the first. Sorry.

Unfortunately, we can’t see them, I just created a private topic and you can attach the archive there


Thanks, we received the archive.

I just tried to deploy it into my app and I can see these timers in the console:


Here is what I see in the console. In addition, there is nothing under the timers folder in the Coding tab for this model. As noted in my original problem statement, I tried deploying the timers in two different files, and in a single file, neither worked.

Hi @Kelly_Oglesby !

Can we try to deploy timers in your app using separate deployment model?

Regards, Andriy

I created an empty project, and added the two timers in two separate files. The model is set to ‘Test’ in coderunner.json. It deployed without errors, but the timers are not shown in the timers tab, and in the Coding tab there is a Test model, but it contains nothing but empty folders.

What all is counted towards the “script count resource” in Cloud 9? This problem started on Nov 17, when I exceeded that resource, and deployment hasn’t worked since. I cleaned out unused testing models, and no longer get such errors, but the deployment still fails in the same way it did the night I exceeded the resource.

Thank you

Hello @Kelly_Oglesby,

The limit on the BL deploy is exceeded:

we’ll add this error to the logs (internal ticket BKNDLSS-27149).

Please, reduce the number of timers you want to deploy or buy the Unlimited Business Logic Scripts pack.


Can someone please tell me what all constitutes a “script.” I can’t relate that 4/5 count to anything that exists in this project. I have deployed 3 Services and use Twilio. Is that the 4th? If I knew what is counted, perhaps I could organize things differently to stay within plan limits.

Hello @Kelly_Oglesby

Current usage of Business Logic scripts = EVENT HANDLERS (PRODUCTION mode + MARKETPLACE mode) + TIMERS (PRODUCTION mode + MARKETPLACE mode).

EVENT HANDLERS in PRODUCTION mode = afterUpload + afterSaveFileFromByteArray = 2
EVENT HANDLERS in MARKETPLACE mode = beforeLogin + beforeRegister = 2
Total = 4

API Services are not limited