Naked domain?

I am looking for naked domain (without www) link to our BE hosted site. I think this will be an A record in our DNS setting of domain host. Please can you advise.

Hello @Louis!

To achieve this, you should create an A record instead of using a CNAME record. To find the IP address required for the A record, you can use the dig command with your backend’s domain, like so: dig develop.backendless.com. This command will provide the IP address that you can then use in your DNS settings.

Regards,
Alexander

@Alexander_Pavelko

I am not running Linux, is there an alternative that doesn’t involve me installing software?

On Windows, you can use the nslookup command in Command Prompt.
Simply type nslookup develop.backendless.com, and it will return the IP address you need for the A record in your DNS settings.

Alternatively, you can also use online DNS lookup tools like https://www.whatsmydns.net/#A/develop.backendless.com.
Enter your domain and select “A” to quickly find the IP.

Regards,
Alexander

@Alexander_Pavelko

I have done this, thank you. Now I am getting error message… {“code”:9070,“message”:“Application is not found by domain ‘xxxxxx.com’. Please contact support to fix the issue.”,“errorData”:{}}

Changes to DNS records can take up to 48 hours to take effect.
If you continue to receive an error after this period, please let us know.

Regards,
Alexander

@Alexander_Pavelko

But I am getting your error message so clearly DNS has taken effect.

{“code”:9070,“message”:“Application is not found by domain ‘xxxxxx.com’. Please contact support to fix the issue.”,“errorData”:{}}

Could you please provide your App ID so that I can check?

Regards,
Alexander

The reason you were receiving error messages is related to the fact that in the application settings, you added a custom domain as www.domain.com, but you intended to use a naked domain and configured it accordingly.
If you change the custom domain to domain.com, everything should work correctly.

Regards,
Alexander

@Alexander_Pavelko OK, so now the site loads for naked domain but with no https and now it does not work for www.

  1. Is it an either/or for naked domain/www, not both?
  2. Do we only get https with www?

Many thanks,

Louis

hello @Louis

www.domain.com and domain.com are different domains if you want to have both, you should both add to backendless application. www.domain.com should have CNAME, and domain.com should have A record.

As I see https://www.domain.com/ works fine and https works for me as expected

@sergey.kuk

The only reason it is working now is that I replaced the CNAME and gave up on naked domain.

If it works as you claim then why does your own website only allow naked domain and not www?!!! Your website is naked only, try it with www → https://www.backendless.com/ If you can’t get it working for yourselves I have doubt you can do it for us.

@Louis

the issue with https://www.backendless.com/ is not related to the issue with your domains.

your domain www.YOURDOMAIN.com configured as cname

dig www.YOURDOMAIN.com

; <<>> DiG 9.10.6 <<>> www.YOURDOMAIN.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45368
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;www.YOURDOMAIN.com.		IN	A

;; ANSWER SECTION:
www.YOURDOMAIN.com.	3600	IN	CNAME	develop.backendless.com.
develop.backendless.com. 762	IN	A	216.87.89.90

;; Query time: 205 msec
;; SERVER: 10.110.10.1#53(10.110.10.1)
;; WHEN: Thu Mar 21 07:46:55 EET 2024
;; MSG SIZE  rcvd: 95

and it works fine

Domain YOURDOMAIN.com has no A Record to 216.87.89.90

dig YOURDOMAIN.com

; <<>> DiG 9.10.6 <<>> YOURDOMAIN.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 50133
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;YOURDOMAIN.com.			IN	A

;; AUTHORITY SECTION:
YOURDOMAIN.com.		300	IN	SOA	ns-cloud-c1.googledomains.com. cloud-dns-hostmaster.google.com. 30 21600 3600 259200 300

;; Query time: 200 msec
;; SERVER: 10.110.10.1#53(10.110.10.1)
;; WHEN: Thu Mar 21 07:50:13 EET 2024
;; MSG SIZE  rcvd: 131

also, the domain YOURDOMAIN.com was removed or not added to the backendless application.

As a result when you call YOURDOMAIN.com you get the following

curl -i YOURDOMAIN.com

curl: (6) Could not resolve host: YOURDOMAIN.com

@sergey.kuk

Well I followed the instructions before, added the A name and the naked domain was not secure and without https, so it was useless to us. Just as I explained to you. That is why I replaced the Cname. we can’t have the website down for days following instructions that don’t work and not getting answers when we identify this. Thank you for the dig though :smiley:

Thank you for the dig though :smiley:

you are welcome

Well I followed the instructions before, added the A name and the naked domain was not secure

it takes some time to generate a cert for the domain, so if you add A record for YOURDOMAIN.com and add this domain to the backendless application we will generate the cert and let you know

@sergey.kuk Thank you

Please confirm, is it possible to have both naked and www at the same time? If so, how do I represent this in BE app settings?

It is possible to have both naked and www at the same time. Please add A record for YOURDOMAIN.com and add this domain to the backendless application (App settings → Custom domains). We will generate the SSL cert and let you know

@Nikita_Fedorishchev Thank you for explaining. We have added the A name to our DNS and successfully saved the new custom domain in app settings. Please generate the SSL cert.

Much appreciated,

Louis

Hi @Louis

SSL is generated, check please on your side

1 Like

It is now working for both www and naked, thank you Sergii :star_struck: