Perfect funktion but no reward

Task: Set Object Relationships with API

Please, describe your problem here.

I have done as the video is telling me and everthing works perfectly. But no reward. How come?

BR, Ove

Something must me missing in your “perfect function” :wink:

Did you do it with code or with Codeless?


I did it with Codeless. It seems that the relation binding is not working. Maybe the button isn´t correct. But in my eyes it is as it should be.



Unfortunately, I cannot see your codeless logic in your previous post, it showsn only the data browser screen.


Well, I can populate a new person by name and age but the relationship binding doesn’t work. How do I show you the codeless logic?

Hello @Ove_Eriksson

You can take a screenshot and attach it as you did earlier for the data browser screen:

Hello @Ove_Eriksson

Could you add logging for the values: createdPerson and selectedCity, using the print block, to make sure they are present and correct.


Not sure what you mean by Print Block.

Something like this:

Then, go to the preview, and before clicking on the open button, inspect the element:

Also, please pay attention to the description of the task:

const retrieveChild = async () => {
  const whereClause = 'Name = \'Dallas\''
  const queryBuilder = Backendless.DataQueryBuilder.create().setWhereClause(whereClause)

the city must be Dallas.


This is before I push the button

   Failed to load resource: the server responded with a status of 400 (Bad Request)

DevTools failed to load source map: Could not load content for chrome-extension://blgajmkampbgaoahecoaamfedgnajleb/generated/ HTTP error: status code 404, net::ERR_UNKNOWN_URL_SCHEME

I give up. You better log in to my app and check by yourself.

Please provide your applicationId, as well as the name of the container and page.


App Id: 91FA5AE8-176D-11C0-FF77-476BEA71C900

Page: createRelation

Container: 1234 if I guess right

Thank you for your patience and help.

/ Ove

This is the logic for when person is created. See the property you’re binding the value to:

This is the logic for creating relation, notice the property name you use there:

Do you see the problem?



I have corrected the property to createdPerson instead of createPerson. The binding is still not working.

Hi, @Ove_Eriksson

Checked one more time, seems like it works now. I was able to set relations via created logic on the createRelation page in UI-Builder. Or did you mean something else when you wrote that it is still not working?

Regards, Marina

I just got worded so everything is ok. Thank you.

1 Like