Support Topics Documentation Slack YouTube Blog

Push notification not working


(Allan) #1

I tried to send a push notification, but none of them is received. None of the registered device can get notification.

APPLICATION_ID 161CA8CE-7AC3-2596-FF77-73632D3ED600
API_KEY 7ABCB71F-AE97-0E17-FFD6-5943634E8F00
I even tried to send from the console, nothing happen.
Tried channels
userwCF3H4FNrmWQ5IshvmyAGUToDhf2
userSLC99TT5ekhCQZSUrQT6fIioBZh2
userbooUWZwoxNZUuLQuNctPJvu0uMZ2
userlGL4ahlFlxTlEhBuBzeoyHDdS5b2
It was working before lunch, and I come back from lunch, it’s not working.
Nothing has changed on my end.


(Sergey Chupov) #2

Hi Allen,

Does the problem still persist? Could you please share your client-side code?


(Allan) #3

No, the problem still persit. The log is saying message published, but no device actually getting notification. The code are in screenshots.

Android response:

01-23 08:17:31.046 5872-5872/E/error: Message published to channel: userSLC99TT5ekhCQZSUrQT6fIioBZh2, response MessageStatus{messageId=‘message:68CA8F12-CE9D-4C48-FF3C-3AE93304C100’, status=SCHEDULED}
01-23 08:17:31.046 5872-5872/E/error: Message published to channel: userlGL4ahlFlxTlEhBuBzeoyHDdS5b2, response MessageStatus{messageId=‘message:B7731CC1-D1BE-9A3F-FF49-193D144D1D00’, status=SCHEDULED}
01-23 08:17:31.176 5872-5872/E/error: Message published to channel: userwCF3H4FNrmWQ5IshvmyAGUToDhf2, response MessageStatus{messageId=‘message:305E799E-2B45-9B46-FF3A-13FE3BAE8E00’, status=SCHEDULED}

iOS response

2018-01-23 08:13:10.251622-0600 [1533:18348] try push to channcel userbooUWZwoxNZUuLQuNctPJvu0uMZ2
2018-01-23 08:13:10.253711-0600[1533:18348] try push to channcel userlGL4ahlFlxTlEhBuBzeoyHDdS5b2

Screen Shot 2018-01-23 at 8.16.39 AM.png


(Allan) #4

There’s another question, my table “DeviceRegistion” should have a column channelName, but I can’t see it from the console, but when I tried to create one, it said channelName already exist.


(Oleg Vyalyh) #5

There’s another question, my table “DeviceRegistion” should have a column channelName, but I can’t see it from the console
It is really strange.

Could you clarify:

  1. It is new app ?
  2. did you make export/import/migration in this app?

(Allan) #6

No, it’s old app, created in Oct 2017, I believed, the channelName used to be there, push notification all working.

I haven’t do any export/import/migration

I only do stuff from mobile side so far.


(Mehmet Aktas) #7

I have the similar problem. I cannot receive notification in my application. It is a working application but as seen in the screenshot, push notification feature suddenly stopped. I got every response after I scheduled or sent the notification but I cannot receive any notifications at all


(Vladimir Upirov) #8

Hi Mehmet

What’s your AppId?


(Mehmet Aktas) #9

Hi Vladimir. My App ID is : 706226DA-3A4D-829E-FF92-9733231F4600

Besides, I was using a custom Push Service class. Today, I deleted everything from my app and started the whole implementation process from the beginning as mentioned in the tutorials. I can register the device, get device ID and token and see them in Backendless console. But when I try to send notification from the console! (Not using the API), I cannot receive the message at all. I debug it from my app but it does not step into onMessage() callback.

Thank you for your support by the way. I’ll be waiting your response.


(Oleg Vyalyh) #10

Hi. We’ve made some changes. Please, try once again with your app.


(Allan) #11

The issue still persist. Already tried to send from android, ios and the console, but no push notification recieved. The column “ChannelName” is still not visible.


(Mehmet Aktas) #12

I tried sending notification using Backendless console and it worked! I do not have much time right now but I quickly tried to use REST API to send delayed push notification and it did not work. But I will test again for the RESt API tomorrow as soon as possible and write here the results.


(Anton Govorushkin) #13

Hi Allan,

It seems to be that your issues are related to the broken schema of your DeviceRegistration table. We’re looking into it and will get back to you with results ASAP.

Mehmet Aktas, I’ve just checked delayed publishing via Android SDK and it’s working on my side. Some additional information required to reproduce the problem.

  1. Has it been working before or you’ve just started integrating push notifications to your project?
  2. Could you please provide the code of how are you scheduling delayed pushes?

Best regards


(Mehmet Aktas) #14

Hi Anton,

It is an active application that is on the market for a while. So I did not integrate push notification recently. I am setting delayed pushes as shown below:

DeliveryOptions deliveryOptions = new DeliveryOptions();
deliveryOptions.setPublishAt(checkDate /* valid java.util.Date object*/ );
List<String> deviceId = new ArrayList<>();
deviceId.add(myDeviceID);
deliveryOptions.setPushSinglecast(deviceId);

PublishOptions publishOptions = new PublishOptions();
HashMap<String, String> headers = new HashMap<>();
headers.put(PublishOptions.ANDROID_TICKER_TEXT_TAG, ticker);
 
headers.put(PublishOptions.ANDROID_CONTENT_TITLE_TAG, title);



headers.put(PublishOptions.ANDROID_CONTENT_TEXT_TAG, text);

publishOptions.setHeaders(headers); 




/*Below code is in AsyncTask*/ 
MessageStatus publishResponse = Backendless.Messaging.publish( myPushMessage, publishOptions, deliveryOptions );

(Anton Govorushkin) #15

Can you confirm, that date you are passing in delivery options is a valid timestamp pointing to the date + time in future?


(Mehmet Aktas) #16

Yes I am sure time is valid and + time in the future. I attached a screenshot which I took at 2018-01-25 at 16.21.41


(Allan) #17

Thanks to look into the issue. I really appreciate it


(Anton Govorushkin) #18

Hi Allan,

Could you please check your DeviceRegistration table again? ChannelName should already be there. If not - clear cache and reload the page.
When done - please check messaging functionality for your application again. If the problems will still persist let us know in this topic

Best regards


(Allan) #19

Hi Anton,

Thanks, I already check all functionality, it’s working now.


(Mehmet Aktas) #20

Hi Anton, issue is stated as solved but what about delayed publishing problem of mine? Is there any update on that?