Urgent: bad request (in production, prevents users from purchasing our product)

The only reason I am asking these questions is to facilitate a fix for you. I thought it would be obvious

We made additional changes. We need a way to validate the fix. The curl you sent me doesn’t work - we’re getting an error about Json format. Could you please provide an instruction for how we could validate. Ideally, it would be through backendless console.


1 Like

thanks Mark, it seems that we are up and running

as the problem impacted all business logic, to test I could just hit GET under the users table

I tried also now with a purchaseorder and it worked fine

I appreciate the help on a weekend, if you have any recommendations for the migration, knowing that we would need to start with 2 parallel systems, I’m all ears

hello team,
this issue is happening again

it does not happen on all calls, but somewhat randomly, sometimes it works, sometimes we get the usual

  "code": 0,
  "message": "Model Descriptor not found (/opt/backendless/repo/9088af67-1648-1726-ff09-a51862bf1a00/files/servercode/JS/v1/model.json)"

to test, from backendless console, under REST console, just call GET from the Users table, you will get sometimes “not authorized”, the correct response for your account, but then if you hit it another 2-3 times, you will get the error above.

The error happens because, as covered above, there is an issue when calling anything that has to do with the business logic. We use business logic right now only for the users table (which is what you can use to test) and for processing purchase orders, which are indeed also failing as reported by our users

thank you for your help in looking into this again

can you confirm that this is now offline because you are looking into it? thank you

Hello @Alessandra_Saviotti

We are taking care of your issue


1 Like


We apologize for the inconvenience. Now the error should not happen again.


1 Like

@viktor.liablin would you be able to check this again? I am now getting again bad requests with the same errors covered above (business logic issues saying that it could not execute in 20 seconds, despite just doing a role check)

“code”: 15000,
“message”: “Custom business logic execution has been terminated because it did not complete in permitted time - 20 seconds”

thank you for your help

Hello,@Alessandra_Saviotti. So there was a bug, fixed.
We apologize for the inconvenience.

Could you check and confirm that everything is fine?

Seems okay now, thank you

@viktor.liablin @Marian_Koreniuk @mark-piller please double check this again, we are getting the same error

with 400 status code response
{“code”:0,“message”:“Model Descriptor not found (/opt/backendless/repo/9088af67-1648-1726-ff09-a51862bf1a00/files/servercode/JS/v1/model.json)”}

as described above, you can replicate just running a GET on the users table. This is again preventing customers from buying our product, already for days

please resolve this and also let me know how we can make sure this does not happen, we keep having the same issue every few weeks

thank you for your help as always

Hello, @Alessandra_Saviotti .

Fixed, so indeed one of the services failed. We apologize for the inconvenience.

1 Like

this is not resolved, please resolve it, we are experiencing again the same problem today, with users unable to purchase a subscription @Marian_Koreniuk

@Alessandra_Saviotti The problem is isolated, I checked that the problem does not appear, check if everything is fine now? I will still working on it out so that the problem does not appear in the future.

1 Like

thank you, working now

@Marian_Koreniuk we are experiencing this issue again, nobody can purchase the product because the business logic is failing (we are the same having this issue: Urgent: bad request (in production, prevents users from purchasing our product) - #40 by Alessandra_Saviotti)

please check this as soon as you can, thank you

@Marian_Koreniuk we have no access to the users table and the whole subscription mechanism is down, this all is related to business logic as these are the two business logic functions we have

these past two weeks have been REALLY hard here, please let’s sort these issues out, we cannot possibly keep operating this way

thank you for your help

it’s been a day that the business logic is down and this is having a large impact on our business

to reproduce the issue, simply do a GET on the Users table, which fails (timeout) due to how the business logic is not operational right now

please somebody reply and help with this, we pay 15 000 dollars / year for backendless and it has been down for 2 weeks for various reasons, the last one this issue with the business logic

@viktor.liablin @mark-piller @Marian_Koreniuk

please somebody reply, I don’t know what to do here anymore as this is outside of our control and nobody in the company is replying to any query

Hello, @Alessandra_Saviotti
Sorry for the delay.

Yes, there really is a problem, but it does not appear in the logs and to diagnose it, we need to really monitor whether your business logic returns a result. In connection with the situation, we will add monitoring specifically to your business logic to see that your service is working or not working.
We will also add logic to fix the problem as soon as a problem arises so that we don’t have to wait for our reaction.

At the moment I checked and the table is not available, check if everything is fine and confirm.

Thank you. The Users table seems to work now, we will try with an order request