Urgent - external API calls are not working

Timers, event handlers and all internal operations are functional but we cannot receive webhooks into our methods. We are receiving this error:

Error while retrieving: The app returned "Service method not found".

Close.com is sending us this message:

Hey Andreas –
We aren’t experiencing any system wide webhook issues. We are receiving errors returned from Backendless for your webhooks though. It looks like the Backendless destination urls are throwing errors when the webhooks try to fire.

Steps to reproduce the error have been sent via message to @staff

I am experiencing the same. This is on EU-servers.

1 Like

I am suddenly getting 400 error on my methods that has been working for months.

My cloud calls are suddenly failing - I know it’s not my cloud code because the errors are occurring before they are called:

Error: Wrong json format: Cannot deserialize value of type `java.lang.String` from Object value (token `JsonToken.START_OBJECT`)
 at [Source: UNKNOWN; byte offset: #UNKNOWN] (through reference chain: java.util.LinkedHashMap["options"])
    at new ResponseError (backendless.js?b8b6:1144:1)
    at checkStatus (backendless.js?b8b6:1355:1)

This is my error-log. This started happening at 16.12 CET today.

It seems like the issue was just fixed, moments ago.

1 Like

Also seeing some of my methods working, seems to be restoring.

1 Like

Still not working here.

The issue should be fixed. If anyone is still experiencing it, please let us know

Im still experiencing the same error @mark-piller

Now the data is coming through, but the webservice posting data still gets an 400-error. In other words: system works, but there still seems to be some kind of issue.

Could you please describe how we can reproduce the problem?

Issue is happening again. Our webhooks are getting 400 errors

“Glad” to know I’m not the only one. Indeed, also on EU server.
Ticket opened here : Sudden error when accessing table

Please Backendless team, would be great if you could fix quickly because API calls are not being reponded to.

1 Like

@Nicolas_REMY I have answered in your topic

None of my external tables are loading and I cannot communicate outside of the app. This is extremely frustrating.

The Backendless team is fixing it. Last time they fixed it very quickly, it should not take long.

Any news @sergey.kuk? We’re you able to reproduce my issue or any similar ticket you have ongoing at the moment?

working now thank you

@Andreas_Marinopoulos I was not able to reproduce it with your application, I have answered in the private topic https://support.backendless.com/t/steps-to-reproduce-ticket/15974/16