Changes are getting undone automatically

It’s very annoying
I am doing changes and publishing them to production.
After a few hours
I am checking changes are getting undone.

Hello @Baljeet_Singh

Is it still doesn’t save after publishing? Can you try one more time, and check if it works. Between publishing and applying, changes exist some delay, but it’s less than one minute as rule.

If this still happens with you, provide me please your app id, describe step by step what are you doing and we investigate your issue.

Regards, Dima.


  1. Suppose I changed a condition today
  2. QA is done from APP we have
  3. After a day, QA said it’s again not working
  4. I checked that my changes are not there
  5. It happens since 3 days.

APP Id is

Sorry for this inconvenience. Could you please:

  • make changes
  • open DevTools(F12) - Console
  • deploy logic
  • send a screenshot with errors(if they happened)

Regards, Dima.

Not getting any error Dima as its happening after deploying, working fine as well.
Changes gone after few hours from server.

Hello @Baljeet_Singh

I can see there is a team of 4 developers in the app and also I can see around 60 deploys for this day (changing BL on the server), so is there any chance that someone from your team erases your changes?
It may not be on purpose, just someone edits the same APIService/Handler/etc. at the same time with you but deploy it later after you

No way @vladimir-upirov
Only I am doing changes and also you can see the IP address if you can from the location we are deploying.
Suppose if anyone is deploying, the changelog should show old changes as those are also not showing.

The scenario you described where the deployed code “is missing blocks” is technically not possible since the deployed code doesn’t have blocks. The only possibility is when someone changes the logic and then deploys it.

The changelog maintains the changes done on your computer only, it doesn’t have any changes made by anyone else. When the logic is deployed, it runs as code, not as codeless blocks. Even if the codeless logic in the form of blocks changes and is not deployed, the code that runs on the server is not impacted.

When you deploy and get a confirmation that the logic is deployed, you can reload the browser to make sure the logic looks exactly as what you had.


@mark-piller Is there any way to track this?
Its happening only in one API. Which screenshot I sent you after that I canged that condition and now its again showing like I didn’t change anything.

Now I am changing it to below screen

and I am closing for the day now and no one will publish till tomorrow.

Can we check the same change on server tomorrow without deploying anything to server?

Try opening that logic in another browser or in Chrome’s incognito mode. Do you see any changes there?

Hi @mark-piller
Just checked now,
Icognito doesn’t show changes right now.
How this use case is possible?

  1. I have done changes
  2. Deployed
  3. QA team tested and its working
  4. After next day QA team said Its not working again

Same thing will be going to happen today now.

I believe it happens because of the “exceeded the quota” error with Browser LocalStorage, as you have shown here Deploying production to Dev enviornment - #10 by Baljeet_Singh

That’s why @Dima asked you to check your browser’s DevConsole to see any errors there Changes are getting undone automatically - #4 by Dima_Vak

The issue has been fixed and it is in the testing stage, we are planning to release it next week, while it’s not I can recommend you to clean up your local storage manually

Okay, Thanks @vladimir-upirov

Still facing this issue.
When will be fixed it?

Hi, @Baljeet_Singh

The issue is in testing, we are planning to release it this week. As soon as the fix is in production, we will let you know.


Okay, Thanks.

@Marina.Rudenko Any update on this, please.
We are very stressed. Daily our changes are undoing automatically.

Hello @Baljeet_Singh

It is look like your localStorage is full.

In this release we have added functionality to help you avoid these problems. This is the Local Storage Cleaner. The following popup will appear if you have reached the local storage limit. This functionality will help display if any Backendless applications are storing data in local storage. This can be either UI-builder data or Codeless Business Logic data. It also has a function to clear Backendless data from the local storage.

If Local Storage Cleaner can’t help you, I recommend you do it manually.
Go to local storage in your browser, and delete every key from here ( screenshot ). ( You must be in the domain )
Don’t forget deploy your codeless logic if it not save

Regard, Viktor

Can we manually open this popup?


No you can’t do it.
It only appears when the local storage is full.
In this popup you can clean only codeless keys.
I am guessing that your storage may be populated with other keys
Thats why I recomend you clean it manualy

Regard, Viktor