Help with Meta scraping


I am trying to authenticate my website URL with Meta in the Meta for developers section.

I am currently unable to do so because the Meta scraper is getting a 400 error code from the URL.

The website URL is and is a custom domain hosted with Backendless on the Cloud 99 plan.

When I use the Meta Sharing debugger (Sharing Debugger - Meta for Developers) I get a 400 error.

When I inspect what their scraper sees, I get this:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "">
<head><meta http-equiv="content-type" content="text/html; charset=utf-8"></head>
<body><p>{"code":8053,"message":"Invalid value 'bytes=0-524287' for 'Range' header. Invalid last byte position 524287","errorData":{}}</p></body>

Is there anything with the way that the server is handling partial content requests that could explain this?

I’ve added meta tags to the site as per the above post, but am still getting the same error

Hello @Luc_Zentar

To solve your problem, we need to add the ability to add custom meta tags. We will discuss it with the team and will inform you when we have an update on this.


@viktor.liablin thank you Viktor, this is business critical for us as we have multiple teams waiting on this being completed before they can complete a big project. Anything you can do to let me know expected timeframes would be very helpful.

Would a workaround similar to this work? - How to set html meta - #5 by mark-piller

Hello @Luc_Zentar!

I’ll be able to provide you with more information regarding the timeline once we’ve discussed this improvement with the team. In the meantime, you can indeed try using the approach of editing the index.html file.
If you have any questions or need assistance, feel free to ask.


@Alexander_Pavelko I haven’t been able to resolve this issue, I’m not sure it’s possible as the error is due to a partial content request and the range header.

Is this something that could be prioritised with paid consultancy from you guys? Like I said, it’s really critical for us to get it resolved.

Hi @Luc_Zentar,

We understand how this is important for you. I have raised a priority of this ticket to critical, we will see what we can do next Monday and will let you know here.


Thank you, very much appreciated

@stanislaw.grin is there any update for this?

Hello, @Luc_Zentar.

This ticket is in our roadmap. Will be done in the next releases.

Regards, Nikita.

Hi @Nikita_Fedorishchev,

Could you put some timeframes around this please? When will the next release be?

Approximately it will take 2-3 weeks.

Thank you @Nikita_Fedorishchev - is there any way we could put custom meta tags on my instance faster than this? Could this be done as paid consultancy by your team?

Hi @Luc_Zentar

You can modify the index.html file after each publishing because it always generates new content.

In order to keep these custom tags nearby the index.html file you can create the custom-tags.html file in the /ui-builder/containers/{CONTAINER_NAME}/custom-tags.html file and then when you publish the container the file will appear in the published folder


Thank you, I’ve added the custom tags as described but still get the same problem

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "">
<head><meta http-equiv="content-type" content="text/html; charset=utf-8"></head>
<body><p>{"code":8053,"message":"Invalid value 'bytes=0-524287' for 'Range' header. Invalid last byte position 524287","errorData":{}}</p></body>

This seems to be a server side issue related to partial content requests using the range header. Are you sure that custom tags can fix this? Can the server configuration be changed instead?

try to add OpenGraph tags

there is nothing to change on the server, it just returns an HTML page and then each client renders the preview using meta tags

Thank you @vladimir-upirov

I have amended the index.html but this isn’t showing on the site in incognito mode. Does it take a while to update or have I done something wrong?

I assume the image should not be “*.ico”

a web browser can cache files for a while, the best way to load the latest version is open the browser dev tool and enable “disable cache” in the network tab

take a look at my test app, seems like it works, the forum displays its preview

Thank you, I’ve changed the imagine to .png

I’ve also disabled cache in network tab and still it doesn’t show.

To check my work:

I go to root > UI Builder > Containers > WebApp and then edit the index.html file

Hello @Luc_Zentar!

You need to edit the index.html of the published app. You can find it in the directory you choose when publishing the container.

For example, if you publish it here:

You’ll need to modify the index.html located in this directory: